CVE Catalog

CVE-2026-112063

MediumCVSS 5.9
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.24%

14th percentile - higher than 14% of all known CVEs

Summary

libstrophe through 0.14.0 contains a stack-based buffer overflow in SCRAM_Hi that allows malicious XMPP servers to overflow a 128-byte stack buffer by sending an oversized SCRAM salt. Attackers can send a server-first-message whose s= attribute decodes to more than 124 bytes.

Risk Assessment

A malicious XMPP server or man-in-the-middle attacker can crash the client or overwrite stack memory, potentially enabling code execution in NDEBUG builds. The risk affects all applications using libstrophe for XMPP connections.

Recommendation

Upgrade libstrophe to a version newer than 0.14.0 as soon as a fix is available. Until then, connect only to trusted XMPP servers.

Related vulnerabilities

Original NVD description (English source)

libstrophe through 0.14.0 contains a stack-based buffer overflow vulnerability in SCRAM_Hi that allows malicious XMPP servers to overflow a 128-byte stack buffer by sending an oversized SCRAM salt. Attackers can send a server-first-message whose s= attribute decodes to more than 124 bytes, aborting the client or overwriting stack memory in NDEBUG builds.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS