CVE Catalog

CVE-2026-110938

HighCVSS 8.7
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.42%

36th percentile - higher than 36% of all known CVEs

Summary

In Eclipse OpenJ9 versions up to 0.63.0, the JITServer component is vulnerable to denial of service due to improper boundary checks during protocol message and reply handling. An unauthenticated remote attacker or malicious JITServer can transmit malformed network payloads that cause out-of-bounds heap reads, immediately crashing the JITServer daemon or client JVM process via a segmentation fault (SIGSEGV).

Risk Assessment

Remote crash of the JITServer service or client JVM can lead to application unavailability and loss of business continuity. In production environments, this may cause severe disruption.

Recommendation

Update Eclipse OpenJ9 to version 0.63.0 or later, which contains the fixes. Until patched, restrict network access to JITServer ports.

Other vulnerabilities in Eclipse OpenJ9

See all
Original NVD description (English source)

In Eclipse OpenJ9 versions up to 0.63.0, the JITServer component is vulnerable to denial of service due to improper boundary checks during protocol message and reply handling. An unauthenticated remote attacker or malicious JITServer can transmit malformed network payloads that cause out-of-bounds heap reads, immediately crashing the JITServer daemon or client JVM process via a segmentation fault (SIGSEGV).

Vulnerability data from NVD (NIST) · CISA KEV · EPSS