CVE-2026-101057
LowCVSS 3.1Exploitation Probability (EPSS)
Low risk1th percentile - higher than 1% of all known CVEs
Summary
The MCP plugin utcp-mcp (part of python-utcp) through 1.1.2 connects to HTTP and WebSocket MCP server URLs from mcpServers configuration without the ensure_secure_url validation, allowing connections to non-HTTPS/WSS or internal hosts. Fixed in 1.1.3 by validating server URLs before connection.
Risk Assessment
An attacker could intercept MCP communication (e.g., credentials) or connect to internal hosts, potentially leading to data leakage or unauthorized access to internal resources.
Recommendation
Upgrade utcp-mcp to version 1.1.3 or later, which validates server URLs before connection. Additionally, ensure mcpServers configuration uses only secure HTTPS/WSS URLs.
Related vulnerabilities
- CVE-2026-95860Critical
In node-opcua (an OPC UA implementation for TypeScript and Node.js), versions 2.42.0 through 2.180.0 do not honor namespace-level access control configured via setDefaultRolePermissions for nodes without explicit per-node permissions. SessionContext.getApplicableRolePermissions reads a missing or null value instead of the configured namespace field, and the null result is treated permissively. As a result, an anonymous network client can write variables or call bound methods when an operator relied on restrictive namespace defaults.
- CVE-2026-82158Critical
Dell Wyse Management Suite versions prior to 2609.0.0.155 contain a cross-site scripting vulnerability (improper neutralization of input during web page generation). A low-privileged attacker with remote access could exploit it to inject script.
- CVE-2026-115732Critical
Incorrect authorization in certificate-name matching in trapperkeeper-authorization, as used by Puppet Server, allows a client holding a CA-signed certificate whose name extends or shortens an authorized hostname to be authorized as that host. This enables impersonation of other nodes and, in Puppet Enterprise, access to certificate-authority administration and remote command execution on managed nodes.
- CVE-2026-115731Critical
Deserialization of untrusted data in Puppet's report-processing code, as used by Puppet Server, allows a client holding any CA-signed agent certificate to execute arbitrary code on the Puppet Server as its service user by submitting a report with a crafted rich-data type via a PUT request. Where the CA autosigns requests without strong verification, an unauthenticated network attacker can obtain such a certificate.
- CVE-2026-95733Critical
A vulnerability exists in a component of HPE Networking Fabric Composer. Successful exploitation could allow an unauthenticated adjacent attacker to execute arbitrary code on the affected system.
- CVE-2026-95732Critical
An authentication bypass vulnerability exists in the underlying operating system of HPE Networking Fabric Composer. Successful exploitation could allow an unauthenticated adjacent attacker to execute arbitrary code on the affected system.
- CVE-2026-95731Critical
Hardcoded password vulnerabilities in the command-line interface of HPE Networking Fabric Composer could allow an unauthenticated remote attacker to access the affected system using hardcoded credentials. Successful exploitation could grant unauthorized administrative access with elevated privileges.
- CVE-2026-63471Critical
Prior to 0.8.1, fastapi-code-generator inserts an OpenAPI path into a generated @app.get(...) route decorator as a single-quoted string without escaping embedded quotes. An attacker-influenced OpenAPI path can close the string and inject a valid Python expression into the decorator argument. Syntactically valid generated code executes with the application's or CI process's privileges when the module is imported.
- CVE-2026-63470Critical
Prior to 0.8.1, fastapi-code-generator inserts Operation.summary into a generated route-handler docstring as a triple-double-quoted string without escaping embedded triple quotes. An attacker-influenced operation summary can close the docstring and inject a valid Python expression statement into the handler body. Syntactically valid generated code executes with the server process's privileges when the affected route handler is called.
- CVE-2026-63469Critical
Prior to 0.8.1, fastapi-code-generator inserts an additional response status-code key into the generated responses={...} route-decorator dictionary as a single-quoted Python string without escaping embedded quotes. An attacker-influenced second non-primary response key can close the dictionary-key literal and inject a valid Python expression. Syntactically valid generated code executes with the application's or CI process's privileges when the module is imported.
Original NVD description (English source)
utcp-mcp (the MCP plugin of python-utcp) through 1.1.2 connects to the HTTP and WebSocket MCP server URLs given in a call template's mcpServers configuration without the ensure_secure_url validation that the HTTP-family plugins apply, so the HTTPS/WSS-or-loopback rule is not enforced. A call template naming a plain-HTTP, non-loopback MCP server URL is dialed as configured, exposing the MCP handshake to network interception and permitting cleartext connections to internal hosts. The mcpServers configuration is operator-authored rather than remote data, and the connection is an MCP handshake rather than an arbitrary request returning a body, which limits practical exploitation; the OAuth2 token_url credential path described in the original report was not reachable in the affected versions, because the OAuth2 handler was never invoked and the call template's auth field was not read. Fixed in utcp-mcp 1.1.3, which validates server URLs before any connection is made.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

