CVE Catalog

CVE-2025-67342

MediumCVSS 4.6
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.18%

7th percentile - higher than 7% of all known CVEs

Summary

RuoYi versions 4.8.1 and earlier contain a stored XSS vulnerability in the /system/menu/edit endpoint. Although the endpoint is protected by an XSS filter, the protection can be bypassed, and because the menu is shared across all users, any user with menu modification permissions can impact all users.

Risk Assessment

An attacker with menu editing permissions can inject a malicious script that executes in the browsers of all system users. This may lead to session theft, account takeover, or further attacks.

Recommendation

Update RuoYi to a version newer than 4.8.1 if available. Restrict menu modification permissions to trusted administrators and consider additional input filtering.

Other vulnerabilities in RuoYi

See all
Original NVD description (English source)

RuoYi versions 4.8.1 and earlier is affected by a stored XSS vulnerability in the /system/menu/edit endpoint. While the endpoint is protected by an XSS filter, the protection can be bypassed. Additionally, because the menu is shared across all users, any user with menu modification permissions can impact all users by exploiting this stored XSS vulnerability.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS