CVE Catalog

CVE-2025-65944

MediumCVSS 5.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.34%

26th percentile - higher than 26% of all known CVEs

Summary

Sentry-Javascript versions 10.11.0 to before 10.27.0 with sendDefaultPii: true can inadvertently send sensitive HTTP headers, including Cookie, to Sentry. These headers are stored in the Sentry organization as part of the trace and could be used by persons with access.

Risk Assessment

A person with access to the Sentry organization could view sensitive values and impersonate or escalate privileges within the application.

Recommendation

Upgrade Sentry-Javascript to 10.27.0 or later and consider disabling sendDefaultPii or filtering sensitive headers.

Related vulnerabilities

Original NVD description (English source)

Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS