CVE-2025-65095
CriticalCVSS 9.4Exploitation Probability (EPSS)
Low risk30th percentile - higher than 30% of all known CVEs
Summary
Lookyloo prior to version 1.35.1 has potential cross-site scripting on index and tree pages. This issue has been patched in version 1.35.1.
Risk Assessment
An attacker can inject malicious scripts, potentially leading to session theft or account takeover.
Recommendation
Upgrade Lookyloo to version 1.35.1 or later.
Other vulnerabilities in Lookyloo
See all- CVE-2026-55835Medium
Lookyloo prior to version 1.39.4 allows an unauthenticated user to trigger the “report a capture” email on demand (which is expected). The /json/<uuid>/report API endpoint (CaptureReport) incorrectly passes the email and comment parameters, overwriting as_admin. When True, as_admin triggers a search query on a MISP instance (if configured) and adds a list of matching URLs to the email sent to the analyst (not the submitter, so there is no risk of information leakage). This could potentially cause a DoS on the MISP instance.
- CVE-2026-73210Medium
A Server-Side Request Forgery (SSRF) vulnerability was found in Lookyloo's PlaywrightCapture when the only_global_lookup option is enabled. Favicon retrieval was performed outside the browser request-routing protections, allowing an attacker to send HTTP requests to internal resources (e.g., loopback, private IPs) via a crafted web page. The patch introduces a common URL validation routine for favicon retrieval, rejecting non-public destinations.
- CVE-2026-66913Medium
Lookyloo does not enforce limits on the decompressed size of uploaded capture archives and compressed HAR files. An attacker can submit a crafted archive that expands to a very large size, exhausting memory and causing denial of service.
- CVE-2025-66460Medium
Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to 1.35.3, Lookyloo passed improperly escaped values to cells rendered in datatables using the orthogonal-data feature. It is definitely exploitable from the popup view, but it is most probably also exploitable in many other places. This vulnerability is fixed in 1.35.3.
- CVE-2025-66459Medium
Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to 1.35.3, a XSS vulnerability can be triggered when a user submits a list of URLs to capture, one of them contains a HTML element, and the capture fails. Then, the error field is populated with an error message that contains the bad URL they tried to capture, triggering the XSS. This vulnerability is fixed in 1.35.3.
- CVE-2025-66458Medium
Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to 1.35.3, there are multiple XSS due to unsafe use of f-strings in Markup. The issue requires a malicious 3rd party server responding with a JSON document containing JS code in a script element. This vulnerability is fixed in 1.35.3.
Original NVD description (English source)
Lookyloo is a web interface that allows users to capture a website page and then display a tree of domains that call each other. Prior to version 1.35.1, there is potential cross-site scripting on index and tree page. This issue has been patched in version 1.35.1.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

