CVE Catalog

CVE-2025-64783

HighCVSS 7.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.21%

10th percentile - higher than 10% of all known CVEs

Summary

DNG SDK versions 1.7.0 and earlier are affected by an Integer Overflow or Wraparound vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Risk Assessment

Opening a crafted DNG file may allow an attacker to execute arbitrary code with the user's privileges. This can lead to system compromise, data theft, or malware installation.

Recommendation

Update DNG SDK to a version newer than 1.7.0 that fixes the integer overflow, and avoid opening untrusted DNG files.

Other vulnerabilities in DNG SDK

See all
Original NVD description (English source)

DNG SDK versions 1.7.0 and earlier are affected by an Integer Overflow or Wraparound vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS