CVE Catalog

CVE-2025-64751

HighCVSS 8.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.29%

20th percentile - higher than 20% of all known CVEs

Summary

OpenFGA is a high-performance and flexible authorization/permission engine. OpenFGA v1.4.0 to v1.11.0 (openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed.

Risk Assessment

Unauthorized access to resources may occur because authorization policies may not be properly enforced. This breaches the Zanzibar-inspired security model.

Recommendation

Update OpenFGA to version 1.11.1 or later, which fixes this vulnerability. Review authorization logs for unusual access patterns.

Other vulnerabilities in OpenFGA

See all
Original NVD description (English source)

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA v1.4.0 to v1.11.0 ( openfga-0.1.34 <= Helm chart <= openfga-0.2.48, v.1.4.0 <= docker <= v.1.11.0) are vulnerable to improper policy enforcement when certain Check and ListObject calls are executed. This issue has been patched in version 1.11.1.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS