CVE Catalog

CVE-2025-62722

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.26%

17th percentile - higher than 17% of all known CVEs

Summary

LinkAce versions 2.3.1 and below contain a Stored Cross-Site Scripting (XSS) vulnerability in the social media sharing functionality. An authenticated user can inject arbitrary JavaScript via the title field with malicious HTML. The code executes in the browser of a user viewing the link details page.

Risk Assessment

Session cookies may be stolen, actions performed on behalf of users, or malware delivered. The vulnerability affects multiple sharing services.

Recommendation

Update LinkAce to version 2.4.0, which fixes the issue. Implement output encoding and input validation for title fields and consider CSP headers.

Other vulnerabilities in LinkAce

See all
Original NVD description (English source)

LinkAce is a self-hosted archive to collect website links. In versions 2.3.1 and below, the social media sharing functionality contains a Stored Cross-Site Scripting (XSS) vulnerability that allows any authenticated user to inject arbitrary JavaScript by creating a link with malicious HTML in the title field. When a user views the link details page and the shareable links are rendered, the malicious JavaScript executes in their browser. This vulnerability affects multiple sharing services and can be exploited to steal session cookies, perform actions on behalf of users, or deliver malware. This issue is fixed in version 2.4.0.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS