CVE Catalog

CVE-2025-62422

HighCVSS 8.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.51%

42th percentile - higher than 42% of all known CVEs

Summary

DataEase versions 2.10.13 and earlier are vulnerable to SQL injection in the /de2api/datasetData/tableField interface. An attacker can craft a malicious tableName parameter to execute arbitrary SQL commands.

Risk Assessment

Arbitrary SQL execution may lead to disclosure, modification, or deletion of database data.

Recommendation

Update DataEase to version 2.10.14. No known workarounds exist — updating is required.

Other vulnerabilities in DataEase

See all
Original NVD description (English source)

DataEase is an open source data visualization and analytics platform. In versions 2.10.13 and earlier, the /de2api/datasetData/tableField interface is vulnerable to SQL injection. An attacker can construct a malicious tableName parameter to execute arbitrary SQL commands. This issue is fixed in version 2.10.14. No known workarounds exist.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS