CVE Catalog

CVE-2025-62372

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.38%

31th percentile - higher than 31% of all known CVEs

Summary

vLLM, an inference engine for large language models, in versions 0.5.5 to before 0.11.1 allows users to crash the engine serving multimodal models by passing embedding inputs with correct ndim but incorrect shape. This is patched in version 0.11.1.

Risk Assessment

An attacker could remotely cause a denial of service (DoS) against vLLM, disrupting applications that rely on multimodal models. This could impact production systems.

Recommendation

Update vLLM to version 0.11.1 or later. Until then, consider restricting API access and monitoring for unusual requests.

Other vulnerabilities in vLLM

See all
Original NVD description (English source)

vLLM is an inference and serving engine for large language models (LLMs). From version 0.5.5 to before 0.11.1, users can crash the vLLM engine serving multimodal models by passing multimodal embedding inputs with correct ndim but incorrect shape (e.g. hidden dimension is wrong), regardless of whether the model is intended to support such inputs (as defined in the Supported Models page). This issue has been patched in version 0.11.1.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS