CVE Catalog

CVE-2025-62171

MediumCVSS 5.9
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.81%

56th percentile - higher than 56% of all known CVEs

Summary

ImageMagick versions prior to 7.1.2-7 and 6.9.13-32 contain an integer overflow in the BMP decoder on 32-bit systems. When calculating the extent value (columns × bits per pixel), the multiplication can overflow and wrap to zero, and the overflow check added for CVE-2025-57803 is placed after the overflow occurs. Only 32-bit builds with manually increased resource limits are affected; 64-bit systems and default limits are not vulnerable. Fixed in 7.1.2-7 and 6.9.13-32.

Risk Assessment

On vulnerable 32-bit systems, a crafted BMP file can cause incorrect calculations and potentially destabilize image processing.

Recommendation

Update ImageMagick to version 7.1.2-7 or 6.9.13-32 (or later); if possible, restore default resource limits.

Other vulnerabilities in ImageMagick

See all
Original NVD description (English source)

ImageMagick is an open source software suite for displaying, converting, and editing raster image files. In ImageMagick versions prior to 7.1.2-7 and 6.9.13-32, an integer overflow vulnerability exists in the BMP decoder on 32-bit systems. The vulnerability occurs in coders/bmp.c when calculating the extent value by multiplying image columns by bits per pixel. On 32-bit systems with size_t of 4 bytes, a malicious BMP file with specific dimensions can cause this multiplication to overflow and wrap to zero. The overflow check added to address CVE-2025-57803 is placed after the overflow occurs, making it ineffective. A specially crafted 58-byte BMP file with width set to 536,870,912 and 32 bits per pixel can trigger this overflow, causing the bytes_per_line calculation to become zero. This vulnerability only affects 32-bit builds of ImageMagick where default resource limits for width, height, and area have been manually increased beyond their defaults. 64-bit systems with size_t of 8 bytes are not vulnerable, and systems using default ImageMagick resource limits are not vulnerable. The vulnerability is fixed in versions 7.1.2-7 and 6.9.13-32.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS