CVE Catalog

CVE-2025-61872

MediumCVSS 6.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.19%

9th percentile - higher than 9% of all known CVEs

Summary

Mahara before 25.04.2 and 24.04.11 are vulnerable to displaying results that can trigger XSS via a malicious search query string. This occurs in the 'search site' feature when using the Elasticsearch7 search plugin. The Elasticsearch function does not properly sanitize input in the query parameter.

Risk Assessment

An attacker can inject a malicious script that executes in the browser of a user viewing search results, potentially leading to session or data theft.

Recommendation

Update Mahara to version 25.04.2 or 24.04.11 (or later), which contains the input sanitization fix in the Elasticsearch7 plugin.

Other vulnerabilities in Mahara

See all
Original NVD description (English source)

Mahara before 25.04.2 and 24.04.11 are vulnerable to displaying results that can trigger XSS via a malicious search query string. This occurs in the 'search site' feature when using the Elasticsearch7 search plugin. The Elasticsearch function does not properly sanitize input in the query parameter.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS