CVE-2025-61821
MediumCVSS 6.8Exploitation Probability (EPSS)
Low risk42th percentile - higher than 42% of all known CVEs
Summary
An XXE vulnerability in ColdFusion allows unauthorized file system reads on the server. Affected versions include 2025.4, 2023.16, 2021.22 and earlier. An attacker can exploit this to access sensitive files, though exploitation depends on conditions beyond the attacker's control.
Risk Assessment
The risk involves potential leakage of confidential data such as configuration files or credentials, which could lead to further escalation. Despite exploitation constraints, the impact on organizational security is significant.
Recommendation
Immediately update ColdFusion to version 2025.5, 2023.17, or 2021.23 (or later). Additionally, restrict server access and monitor logs for suspicious XML requests.
Other vulnerabilities in ColdFusion
See all- CVE-2026-75994Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. The vulnerable component is restricted to an administrative network zone by default. Exploitation of this issue does not require user interaction. Scope is changed.
- CVE-2026-106624Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106622Critical
ColdFusion is affected by a Server-Side Request Forgery (SSRF) vulnerability that could result in privilege escalation. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106621Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. Exploitation does not require user interaction.
- CVE-2026-106620Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could bypass security measures and gain unauthorized write access. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106619Critical
ColdFusion is affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation depends on conditions beyond the attacker's control and does not require user interaction, and the scope is changed.
- CVE-2026-106612Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-105903Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-105899Critical
ColdFusion is affected by an Unrestricted Upload of File with Dangerous Type vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-75746Critical
ColdFusion is affected by an SQL Injection vulnerability that could result in arbitrary code execution in the context of the current user. An attacker with high privileges could exploit this to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
Original NVD description (English source)
ColdFusion versions 2025.4, 2023.16, 2021.22 and earlier are affected by an Improper Restriction of XML External Entity Reference ('XXE') vulnerability that could lead to arbitrary file system read. An attacker could exploit this vulnerability to access sensitive files and data on the server. Exploit depends on conditions beyond the attacker's control. Exploitation of this issue does not require user interaction and scope is changed.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

