CVE-2025-61457
MediumCVSS 6.1Exploitation Probability (EPSS)
Low risk25th percentile - higher than 25% of all known CVEs
Summary
code16 Sharp v9.6.6 is vulnerable to Cross Site Scripting (XSS) src/Form/Fields/SharpFormUploadField.php.
Risk Assessment
An attacker can inject malicious scripts that execute in the user's browser, potentially leading to session data theft or other attacks.
Recommendation
Update code16 Sharp to a version later than 9.6.6 that includes the XSS fix.
Other vulnerabilities in code16 Sharp
See all- CVE-2026-61825High
code16 Sharp, a Laravel-based framework for building content-management and administrative interfaces, prior to 9.22.5 contains a stored cross-site scripting vulnerability in SharpEditorFormField. Attacker-controlled content bearing the data-html-content attribute can bypass HTML sanitization and preserve executable markup, which may execute when another user views the stored content. Version 9.22.5 is identified as patched.
- CVE-2026-61823High
code16 Sharp, a Laravel-based framework for building content-management and administrative interfaces, prior to 9.22.5 contains a stored cross-site scripting vulnerability in the rich-text editor because the HTML sanitizer permits the srcdoc attribute on iframe elements. Although markup inside srcdoc is HTML-encoded during sanitization, browsers decode attribute entities before interpreting the iframe document, allowing an authenticated user with permission to edit an Editor field to store executable JavaScript that runs when another user views the content. Version 9.22.5 removes srcdoc from permitted iframe attributes.
Original NVD description (English source)
code16 Sharp v9.6.6 is vulnerable to Cross Site Scripting (XSS) src/Form/Fields/SharpFormUploadField.php.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

