CVE Catalog

CVE-2025-59425

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.57%

46th percentile - higher than 46% of all known CVEs

Summary

vLLM before version 0.11.0rc2 validates API keys using a method vulnerable to a timing attack, as string comparison takes longer the more characters are correct. Analysis across many attempts could allow an attacker to determine the next correct character and bypass authentication.

Risk Assessment

Deployments relying on vLLM's built-in API key validation are vulnerable to authentication bypass, potentially allowing unauthorized access to models and resources.

Recommendation

Update vLLM to version 0.11.0rc2 or later, which fixes the timing attack vulnerability.

Other vulnerabilities in vLLM

See all
Original NVD description (English source)

vLLM is an inference and serving engine for large language models (LLMs). Before version 0.11.0rc2, the API key support in vLLM performs validation using a method that was vulnerable to a timing attack. API key validation uses a string comparison that takes longer the more characters the provided API key gets correct. Data analysis across many attempts could allow an attacker to determine when it finds the next correct character in the key sequence. Deployments relying on vLLM's built-in API key validation are vulnerable to authentication bypass using this technique. Version 0.11.0rc2 fixes the issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS