CVE Catalog

CVE-2025-59337

MediumCVSS 6.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.30%

21th percentile - higher than 21% of all known CVEs

Summary

Discourse versions 3.5.0 and below allow malicious meta-commands to be embedded in a backup dump and executed during restore. In multisite setups, this allowed an admin of one site to access data or credentials from other sites. The issue is fixed in version 3.5.1.

Risk Assessment

An admin of one site in a multisite installation can access data and credentials of other sites, breaking isolation and confidentiality. The risk mainly affects multi-tenant environments with untrusted administrators.

Recommendation

Update Discourse to version 3.5.1 or later. Additionally, restrict backup restore privileges and verify the integrity of dumps.

Other vulnerabilities in Discourse

See all
Original NVD description (English source)

Discourse is an open-source community discussion platform. In versions 3.5.0 and below, malicious meta-commands could be embedded in a backup dump and executed during restore. In multisite setups, this allowed an admin of one site to access data or credentials from other sites. This issue is fixed in version 3.5.1.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS