CVE Catalog

CVE-2025-58436

MediumCVSS 5.1
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.23%

13th percentile - higher than 13% of all known CVEs

Summary

OpenPrinting CUPS before version 2.4.15 is vulnerable to a slowloris-style attack. A client sending very slow messages (e.g. one byte per second) blocks cupsd, preventing other clients from being served.

Risk Assessment

An attacker can cause a denial of service (DoS) of the entire print server, blocking printing for all users in the organization.

Recommendation

Update OpenPrinting CUPS to version 2.4.15 or later. Consider restricting access to the cupsd service to trusted networks only.

Other vulnerabilities in OpenPrinting CUPS

See all
Original NVD description (English source)

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a client that connects to cupsd but sends slow messages, e.g. only one byte per second, delays cupsd as a whole, such that it becomes unusable by other clients. This issue has been patched in version 2.4.15.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS