CVE Catalog

CVE-2025-58054

LowCVSS 3.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.20%

10th percentile - higher than 10% of all known CVEs

Summary

Discourse versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.

Risk Assessment

An attacker could inject a malicious script that executes in other users' browsers, potentially leading to session theft or actions on behalf of the victim.

Recommendation

Update Discourse to version 3.5.1 or later, which includes the fix for XSS in chat titles.

Other vulnerabilities in Discourse

See all
Original NVD description (English source)

Discourse is an open-source community discussion platform. Versions 3.5.0 and below are vulnerable to XSS attacks through parsing and rendering of chat channel titles and chat thread titles via the quote message functionality when using the rich text editor. This issue is fixed in version 3.5.1.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS