CVE Catalog

CVE-2025-57822

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
2.58%

85th percentile - higher than 85% of all known CVEs

Summary

In Next.js prior to versions 14.2.32 and 15.4.7, using next() without explicitly passing the request object could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. The vulnerability is fixed in versions 14.2.32 and 15.4.7.

Risk Assessment

Organizations self-hosting Next.js with custom middleware logic may be exposed to server-side requests to unexpected resources (SSRF), potentially revealing internal services or enabling further attacks.

Recommendation

Upgrade Next.js to version 14.2.32 or 15.4.7 (or later) and verify that next() is called with the request object explicitly passed.

Other vulnerabilities in Next.js

See all
Original NVD description (English source)

Next.js is a React framework for building full-stack web applications. Prior to versions 14.2.32 and 15.4.7, when next() was used without explicitly passing the request object, it could lead to SSRF in self-hosted applications that incorrectly forwarded user-supplied headers. This vulnerability has been fixed in Next.js versions 14.2.32 and 15.4.7. All users implementing custom middleware logic in self-hosted environments are strongly encouraged to upgrade and verify correct usage of the next() function.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS