CVE-2025-55728
CriticalCVSS 10.0Exploitation Probability (EPSS)
Elevated risk56th percentile - higher than 56% of all known CVEs
Summary
XWiki Remote Macros versions 1.0 through before 1.26.5 fail to escape the classes parameter in the panel macro, allowing XWiki syntax injection and remote code execution by any user who can edit any page. Version 1.26.5 contains a patch.
Risk Assessment
A user with page edit permissions can execute arbitrary code on the XWiki server, potentially leading to compromise of the application and data.
Recommendation
Update XWiki Remote Macros to version 1.26.5 or later.
Other vulnerabilities in XWiki Remote Macros
See all- CVE-2026-44179Critical
The `excerpt-include` macro in XWiki Remote Macros does not properly escape the included page's title and executes `excerpt` content with the macro's rights. Both the title handling and the rendering of `excerpt` content into XWiki syntax allow syntax injection. Any user able to edit a page, even without script rights, can supply executable macro syntax and cause remote code execution when the page is included.
- CVE-2025-55727Critical
XWiki Remote Macros versions 1.0 through before 1.26.5 fail to escape the width parameter in the column macro, allowing XWiki syntax injection. This enables remote code execution for users who can edit pages or access the CKEditor converter.
- CVE-2025-65089Medium
In XWiki Remote Macros prior to version 1.27.0, a user with no view rights on a page may see the content of an office attachment displayed with the view file macro. This issue has been patched in version 1.27.0.
Original NVD description (English source)
XWiki Remote Macros provides XWiki rendering macros that are useful when migrating content from Confluence. Starting in version 1.0 and prior to version 1.26.5, missing escaping of the classes parameter in the panel macro allows remote code execution for any user who can edit any page The classes parameter is used without escaping in XWiki syntax, thus allowing XWiki syntax injection which enables remote code execution. Version 1.26.5 contains a patch for the issue.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

