CVE-2025-52863
HighCVSS 8.1Exploitation Probability (EPSS)
Low risk28th percentile - higher than 28% of all known CVEs
Summary
A buffer overflow vulnerability affects several QNAP operating system versions. If a remote attacker gains a user account, they can exploit it to modify memory or crash processes.
Risk Assessment
Memory modification or process crashes can lead to system integrity compromise, unauthorized access, or service disruption.
Recommendation
Update QNAP systems to the fixed versions: QTS 5.2.7.3256 build 20250913 or later, QuTS hero h5.2.7.3256 build 20250913 or later, QuTS hero h5.3.0.3192 build 20250716 or later.
Other vulnerabilities in QNAP OS
See all- CVE-2025-62849Critical
An SQL injection vulnerability has been reported to affect several QNAP operating system versions. Remote attackers can exploit the vulnerability to execute unauthorized code or commands. Fixes are available in QTS 5.2.7.3297 build 20251024 and later, QuTS hero h5.2.7.3297 build 20251024 and later, and QuTS hero h5.3.1.3292 build 20251024 and later.
- CVE-2025-59385Critical
An authentication bypass by spoofing vulnerability has been reported to affect several QNAP operating system versions. Remote attackers can exploit the vulnerability to access resources which are not otherwise accessible without proper authentication. Fixes are available in QTS 5.2.7.3297 build 20251024 and later, QuTS hero h5.2.7.3297 build 20251024 and later, and QuTS hero h5.3.1.3292 build 20251024 and later.
- CVE-2026-24716High
NULL pointer dereference vulnerability in QNAP operating systems. A remote attacker with an administrator account can exploit this to cause a denial-of-service (DoS) attack.
- CVE-2025-66281High
A NULL pointer dereference vulnerability has been found in QNAP operating systems (QTS and QuTS hero). A remote attacker can exploit this vulnerability to launch a denial-of-service (DoS) attack.
- CVE-2025-66280High
An integer overflow or wraparound vulnerability has been reported to affect several QNAP operating system versions. If a remote attacker gains an administrator account, they can then exploit the vulnerability to compromise the security of the system. The issue has been fixed in versions: QTS 5.2.9.3410 build 20260214 and later, QuTS hero h5.2.9.3410 build 20260214 and later, QuTS hero h5.3.4.3500 build 20260520 and later, QuTS hero h6.0.0.3397 build 20260206 and later.
- CVE-2025-66279High
A command injection vulnerability in QNAP operating systems. A remote attacker with an administrator account can execute arbitrary commands.
- CVE-2025-66273High
A command injection vulnerability in QNAP operating systems. A remote attacker with an administrator account can execute arbitrary commands.
- CVE-2025-62858Medium
A buffer overflow vulnerability has been reported in several QNAP operating system versions. A remote attacker with an administrator account can exploit it to modify memory or crash processes.
- CVE-2026-41539Medium
Several QNAP operating systems (QTS, QuTS hero) have an XSS vulnerability that can be exploited by a remote attacker to bypass security mechanisms or read application data. Fixed in QTS 5.2.9.3492, QuTS hero h5.2.9.3499, h5.3.4.3500, and h6.0.0.3500 (or later).
- CVE-2025-9110High
An exposure of sensitive system information to an unauthorized control sphere vulnerability affects several QNAP operating system versions. Remote attackers can exploit the vulnerability to read application data. Fixed versions include QTS 5.2.8.3332 build 20251128 and later, QuTS hero h5.2.8.3321 build 20251117 and later, and QuTS hero h5.3.1.3250 build 20250912 and later.
Original NVD description (English source)
A buffer overflow vulnerability has been reported to affect several QNAP operating system versions. If a remote attacker gains a user account, they can then exploit the vulnerability to modify memory or crash processes. We have already fixed the vulnerability in the following versions: QTS 5.2.7.3256 build 20250913 and later QuTS hero h5.2.7.3256 build 20250913 and later QuTS hero h5.3.0.3192 build 20250716 and later
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

