CVE Catalog

CVE-2025-5244

MediumCVSS 5.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.28%

20th percentile - higher than 20% of all known CVEs

Summary

A critical vulnerability was found in GNU Binutils up to 2.44 in the elf_gc_sweep function of bfd/elflink.c in the ld component. Manipulation leads to memory corruption. The attack must be approached locally, and the exploit has been disclosed to the public and may be used.

Risk Assessment

A local attacker can exploit this vulnerability to cause memory corruption, potentially leading to arbitrary code execution or system crash. Since the exploit is publicly available, the risk is high.

Recommendation

It is recommended to upgrade GNU Binutils to version 2.45, which addresses this issue.

Other vulnerabilities in GNU Binutils

See all
Original NVD description (English source)

A vulnerability was found in GNU Binutils up to 2.44. It has been rated as critical. Affected by this issue is the function elf_gc_sweep of the file bfd/elflink.c of the component ld. The manipulation leads to memory corruption. An attack has to be approached locally. The exploit has been disclosed to the public and may be used. Upgrading to version 2.45 is able to address this issue. It is recommended to upgrade the affected component.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS