CVE-2025-48729
MediumCVSS 4.9Exploitation Probability (EPSS)
Low risk39th percentile - higher than 39% of all known CVEs
Summary
A NULL pointer dereference vulnerability affects several QNAP operating system versions. A remote attacker who gains an administrator account can exploit it to launch a denial-of-service (DoS) attack.
Risk Assessment
An attacker with an administrator account can crash the system, causing service and device unavailability.
Recommendation
Update QTS to version 5.2.6.3195 build 20250715 or later, and QuTS hero to version h5.2.6.3195 build 20250715 or later.
Other vulnerabilities in QNAP QTS
See all- CVE-2017-7629High
QNAP QTS before version 4.2.6 build 20170517 has a flaw in the change password function.
- CVE-2017-5227High
QNAP QTS before version 4.2.4 Build 20170313 allows local users to obtain sensitive Domain Administrator password information by reading data in an XOR format within the /etc/config/uLinux.conf configuration file.
- CVE-2015-6003High
CVE-2015-6003 is a directory traversal vulnerability in QNAP QTS before version 4.1.4 build 0910 and 4.2.x before version 4.2.0 RC2 build 0910, when AFP is enabled. It allows remote attackers to read or write to arbitrary files by leveraging access to an OS X user or guest account.
- CVE-2018-19953MediumActively exploited
A cross-site scripting (XSS) vulnerability in QNAP QTS systems could allow remote attackers to inject malicious code. Fixed in specific QTS versions.
- CVE-2018-19949CriticalActively exploited
If exploited, this command injection vulnerability could allow remote attackers to run arbitrary commands. QNAP has already fixed the issue in the following QTS versions. QTS 4.4.2.1231 on build 20200302; QTS 4.4.1.1201 on build 20200130; QTS 4.3.6.1218 on build 20200214; QTS 4.3.4.1190 on build 20200107; QTS 4.3.3.1161 on build 20200109; QTS 4.2.6 on build 20200109.
- CVE-2018-19943HighActively exploited
A cross-site scripting (XSS) vulnerability in QNAP QTS systems could allow remote attackers to inject malicious code. Fixed in specific QTS versions.
- CVE-2019-7193CriticalActively exploited
This improper input validation vulnerability allows remote attackers to inject arbitrary code to the system. To fix the vulnerability, QNAP recommend updating QTS to their latest versions.
- CVE-2017-17033Critical
A buffer overflow vulnerability in the password function in QNAP QTS versions 4.2.6, 4.3.3.0378, 4.3.4.0387 (Beta 2) and earlier could allow remote attackers to execute arbitrary code on NAS devices.
- CVE-2017-17030Critical
A buffer overflow vulnerability in the login function in QNAP QTS affects versions 4.2.6, 4.3.3.0378, 4.3.4.0387 (Beta 2) and earlier. This could allow remote attackers to execute arbitrary code on NAS devices.
- CVE-2017-17029Critical
A buffer overflow vulnerability in the login function in QNAP QTS affects versions 4.2.6 build 20171026, 4.3.3.0378 build 20171117, 4.3.4.0387 (Beta 2) build 20171116 and earlier. This could allow remote attackers to execute arbitrary code on NAS devices.
Original NVD description (English source)
A NULL pointer dereference vulnerability has been reported to affect several QNAP operating system versions. If a remote attacker gains an administrator account, they can then exploit the vulnerability to launch a denial-of-service (DoS) attack. We have already fixed the vulnerability in the following versions: QTS 5.2.6.3195 build 20250715 and later QuTS hero h5.2.6.3195 build 20250715 and later
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

