CVE Catalog

CVE-2025-46819

MediumCVSS 6.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
1.06%

64th percentile - higher than 64% of all known CVEs

Summary

Redis versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server, leading to denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

Risk Assessment

An authenticated user can cause a Redis server crash or read unauthorized data, potentially leading to service disruption and information disclosure. The risk affects organizations using Redis with Lua scripting enabled.

Recommendation

Upgrade Redis to version 8.2.2 or later. A workaround is to prevent users from executing Lua scripts using ACL to block both the EVAL and FUNCTION command families.

Other vulnerabilities in Redis

See all
Original NVD description (English source)

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS