CVE Catalog

CVE-2025-46817

HighCVSS 7.0
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

High risk
3.83%

90th percentile - higher than 90% of all known CVEs

Summary

Redis versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

Risk Assessment

An authenticated attacker could exploit this vulnerability to execute arbitrary code on the Redis server, potentially leading to full system compromise and access to stored data.

Recommendation

Update Redis to version 8.2.2 or later. Restrict access to the Redis server and enforce strong authentication.

Other vulnerabilities in Redis

See all
Original NVD description (English source)

Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS