CVE-2025-40773
LowCVSS 3.5Exploitation Probability (EPSS)
Low risk9th percentile - higher than 9% of all known CVEs
Summary
A vulnerability has been identified in SiPass integrated (All versions < V3.0). The affected server applications contain a broken access control vulnerability. The authorization mechanism lacks sufficient server-side checks, allowing an attacker to execute a specific API request.
Risk Assessment
An attacker can manipulate data belonging to other users, potentially leading to data integrity violations and unauthorized changes in the system.
Recommendation
It is recommended to update SiPass integrated to version V3.0 or later, which includes a fix, and to implement additional access controls.
Other vulnerabilities in SiPass integrated
See all- CVE-2025-40774Medium
A vulnerability has been identified in SiPass integrated (All versions < V3.0). Affected server applications store user passwords encrypted in its database. Decryption keys are accessible to users with administrative privileges, allowing them to recover passwords. Successful exploitation of this vulnerability allows an attacker to obtain and use valid user passwords. This can lead to unauthorized access to user accounts, data breaches, and potential system compromise.
- CVE-2025-40772High
A stored Cross-Site Scripting (XSS) vulnerability has been identified in SiPass integrated (all versions < V3.0) server applications. An attacker can inject malicious code that is executed by other users when they visit the affected page.
- CVE-2022-31810High
A vulnerability has been identified in SiPass integrated (All versions < V2.90.3.8). Affected server applications improperly check the size of data packets received for the configuration client login, causing a stack-based buffer overflow. This could allow an unauthenticated remote attacker to crash the server application, creating a denial of service condition.
- CVE-2022-31808High
A vulnerability in SiPass integrated AC5102 (ACC-G2) (versions < V2.85.44) and ACC-AP (versions < V2.85.43) improperly sanitizes user input on the telnet command line interface. An authenticated user could escalate privileges by injecting arbitrary commands executed with root privileges.
Original NVD description (English source)
A vulnerability has been identified in SiPass integrated (All versions < V3.0). Affected server applications contains a broken access control vulnerability. The authorization mechanism lacks sufficient server-side checks, allowing an attacker to execute a specific API request. Successful exploitation allows an attacker to potentially manipulate data belonging to other users.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

