CVE-2025-3512
MediumCVSS 4.8Exploitation Probability (EPSS)
Low risk13th percentile - higher than 13% of all known CVEs
Summary
A heap-based buffer overflow vulnerability was found in QTextMarkdownImporter in Qt. It occurs when processing a malformed Markdown file. Affects Qt versions 6.8.0 to 6.8.4; versions up to 6.6.0 are unaffected, and the fix is in 6.8.4 and later.
Risk Assessment
An attacker can remotely cause application crashes or potentially execute arbitrary code by providing a crafted Markdown file.
Recommendation
Upgrade Qt to version 6.8.4 or later.
Other vulnerabilities in Qt
See all- CVE-2026-100140Low
An integer overflow vulnerability exists in the Qt XML parsing functionality (Qt5Compat / QXmlSimpleReader). It may cause incorrect parser behavior when processing crafted XML data.
- CVE-2026-107590Low
An out-of-bounds write vulnerability in the Qt QTextCodec iconv-based encoding of the Qt 5 Compatibility APIs module (Qt Core in Qt 5 and earlier) impacts Qt. Under certain conditions, encoding text with QTextCodec may write outside an internal buffer, which can cause the application to crash and may affect data integrity.
- CVE-2025-6338Critical
Incomplete cleanup in Qt Network's Schannel support on Windows can lead to a Denial of Service over time. Affects Qt from 5.15.0 through 6.8.3 and from 6.9.0 before 6.9.2.
- CVE-2023-51714Critical
In the HTTP2 implementation in Qt before 5.15.17, 6.2.11, 6.5.4, and 6.6.2, there is an incorrect HPack integer overflow check in hpacktable.cpp.
- CVE-2026-105924Medium
A NULL pointer dereference vulnerability in the Qt QCborValue to JSON conversion of the Qt Core module. It may lead to application crashes when processing CBOR data.
- CVE-2026-107472Medium
An out-of-bounds read vulnerability in the QTextCodec TSCII encoding of the Qt 5 Compatibility APIs module (Qt Core in Qt 5 and earlier) impacts Qt. Applications that convert text to the TSCII encoding through QTextCodec may read memory outside the input buffer, which can cause the application to crash or misinterpret the data.
- CVE-2026-107157Low
Specially crafted CBOR input passed to QCborValue::fromCbor() in Qt Core can cause an out-of-bounds read, which may crash the application and could expose information.
- CVE-2026-101201Medium
A malformed header in the binary file fed to QBinaryJson::fromBinaryData() can cause undefined behaviour because of an out-of-bounds read.
- CVE-2026-78253Low
Uncontrolled recursion in QXmlStreamReader::readElementText() in Qt Group Qt allows attackers to cause a denial of service (application crash via stack exhaustion) via a crafted XML document.
- CVE-2026-19248High
QDomDocument XML parsing is vulnerable to a remotely-triggerable denial-of-service crash when processing untrusted input.
Original NVD description (English source)
There is a Heap-based Buffer Overflow vulnerability in QTextMarkdownImporter. This requires an incorrectly formatted markdown file to be passed to QTextMarkdownImporter to trigger the overflow. This issue affects Qt from 6.8.0 to 6.8.4. Versions up to 6.6.0 are known to be unaffected, and the fix is in 6.8.4 and later.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

