CVE Catalog

CVE-2025-34253

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.54%

45th percentile - higher than 45% of all known CVEs

Summary

D-Link Nuclias Connect firmware versions <= 1.3.1.4 contain a stored cross-site scripting (XSS) vulnerability due to improper sanitization of the 'Network' field when editing configuration, creating a profile, and adding a network. An authenticated attacker can inject arbitrary JavaScript executed in the context of other users viewing the profile entry.

Risk Assessment

An authenticated attacker can execute arbitrary JavaScript in the browsers of other administrative panel users, potentially hijacking their sessions. The risk affects D-Link Nuclias Connect devices with firmware <= 1.3.1.4.

Recommendation

Update D-Link Nuclias Connect firmware to version 1.3.1.5 or later. Restrict administrative panel access to trusted networks.

Other vulnerabilities in D-Link Nuclias Connect

See all
Original NVD description (English source)

D-Link Nuclias Connect firmware versions <= 1.3.1.4 contain a stored cross-site scripting (XSS) vulnerability due to improper sanitization of the 'Network' field when editing the configuration, creating a profile, and adding a network. An authenticated attacker can inject arbitrary JavaScript to be executed in the context of other users viewing the profile entry. NOTE: D-Link fixed this issue in version 1.3.1.5.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS