CVE-2025-13787
MediumCVSS 5.4Exploitation Probability (EPSS)
Low risk30th percentile - higher than 30% of all known CVEs
Summary
A flaw has been found in ZenTao up to 21.7.6-8564. The affected element is the function file::delete of the file module/file/control.php of the component File Handler. Executing manipulation of the argument fileID can lead to improper privilege management. It is possible to launch the attack remotely. Upgrading to version 21.7.7 is sufficient to fix this issue.
Risk Assessment
Improper privilege management may allow an unauthorized user to delete files they should not have access to, potentially leading to data loss or system integrity compromise.
Recommendation
Immediately upgrade ZenTao to version 21.7.7 or later to remediate the vulnerability.
Other vulnerabilities in ZenTao
See all- CVE-2025-13789Medium
A vulnerability was found in ZenTao up to 21.7.6-8564. The makeRequest function in the file module/ai/model.php allows manipulation of the Base argument, leading to Server-Side Request Forgery (SSRF). The attack can be launched remotely, and the exploit has been made public.
- CVE-2022-4984High
ZenTao Biz < 6.5, ZenTao Max < 3.0, ZenTao Open Source Edition < 16.5, and ZenTao Open Source Edition < 16.5.beta1 contain an SQL injection vulnerability in the login functionality. The application does not properly validate the account parameter on /zentao/user-login.html before using it in a database query. A remote unauthenticated attacker can exploit this issue to execute crafted SQL expressions and retrieve sensitive information from the backend database, including user and application data. Exploitation evidence was observed by the Shadowserver Foundation on 2025-02-07 UTC.
- CVE-2022-37700High
Directory Traversal vulnerability in Zentao Demo15 allows remote attackers to read sensitive information by manipulating the URL. Attackers can access system configuration files.
Original NVD description (English source)
A flaw has been found in ZenTao up to 21.7.6-8564. The affected element is the function file::delete of the file module/file/control.php of the component File Handler. Executing manipulation of the argument fileID can lead to improper privilege management. It is possible to launch the attack remotely. Upgrading to version 21.7.7 is sufficient to fix this issue. You should upgrade the affected component.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

