CVE Catalog

CVE-2025-12483

MediumCVSS 6.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.30%

21th percentile - higher than 21% of all known CVEs

Summary

The Visualizer: Tables and Charts Manager for WordPress plugin in versions up to and including 3.11.12 is vulnerable to SQL Injection via the 'query' parameter due to insufficient escaping and lack of query preparation. Authenticated attackers with Contributor-level access or higher can append additional SQL queries to extract sensitive information from the database. Version 3.11.13 raises the minimum user level to administrator, and 3.11.14 fully patches the vulnerability.

Risk Assessment

This may lead to unauthorized access to database data, including user and configuration data, by low-privileged users.

Recommendation

Update the Visualizer plugin to version 3.11.14 or later, which fully patches the vulnerability.

Other vulnerabilities in Visualizer

See all
Original NVD description (English source)

The Visualizer: Tables and Charts Manager for WordPress plugin for WordPress is vulnerable to SQL Injection via the 'query' parameter in all versions up to, and including, 3.11.12 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Version 3.11.13 raises the minimum user-level for exploitation to administrator. 3.11.14 fully patches the vulnerability.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS