CVE Catalog

CVE-2025-12070

MediumCVSS 4.3
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.16%

5th percentile - higher than 5% of all known CVEs

Summary

The ViaAds plugin for WordPress versions up to and including 2.1.2 is vulnerable to Cross-Site Request Forgery due to missing nonce validation on the ViaAds_pluginHandler function, allowing unauthenticated attackers to modify the plugin's API key and cookie consent settings.

Risk Assessment

An attacker could trick an administrator into clicking a link and unknowingly changing the plugin's configuration, potentially leading to further attacks or privacy breaches.

Recommendation

Update the ViaAds plugin to a version above 2.1.2 that includes the fix. Until then, consider disabling the plugin.

Related vulnerabilities

Original NVD description (English source)

The ViaAds plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.1.2. This is due to missing nonce validation on the `ViaAds_pluginHandler` function. This makes it possible for unauthenticated attackers to modify the plugin's API key and cookie consent settings via a forged request granted they can trick an administrator into performing an action such as clicking on a link.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS