CVE-2025-10099
LowCVSS 2.4Exploitation Probability (EPSS)
Low risk21th percentile - higher than 21% of all known CVEs
Summary
Portabilis i-Educar up to 2.10 contains a cross-site scripting vulnerability in /intranet/educar_usuario_cad.php (user edit page). Manipulating the email/data_inicial/data_expiracao arguments allows remote XSS attacks, and a public exploit is available.
Risk Assessment
An attacker can execute malicious script in a victim's browser, hijack sessions, or perform actions on the user's behalf. Public exploit availability increases the risk.
Recommendation
Upgrade i-Educar to version 2.12 (patch 5b11c0376fcef7ada4c90760b0ca1ed2f16c4de9).
Other vulnerabilities in Portabilis i-Educar
See all- CVE-2026-2015Medium
A vulnerability was detected in Portabilis i-Educar up to version 2.10. It affects an unknown function in FinalStatusImportService.php of the Final Status Import component. Manipulation of the school_id argument leads to improper authorization. The attack can be executed remotely, and the exploit is public. Upgrading to version 2.11.0 addresses the issue.
- CVE-2025-11554Medium
A security vulnerability has been detected in Portabilis i-Educar up to 2.9.10. Affected by this issue is some unknown functionality of the file app/Http/Controllers/AccessLevelController.php of the component User Type Handler. The manipulation leads to insecure inherited permissions. The attack may be initiated remotely. The exploit has been disclosed publicly and may be used.
- CVE-2025-11050Medium
A flaw has been found in Portabilis i-Educar up to 2.10. This affects an unknown part of the file /periodo-lancamento. Executing manipulation can lead to improper authorization. The attack can be executed remotely. The exploit has been published and may be used.
- CVE-2025-11049Medium
A vulnerability was detected in Portabilis i-Educar up to 2.10. Affected by this issue is some unknown functionality of the file /unificacao-aluno. Performing manipulation results in improper authorization. Remote exploitation of the attack is possible. The exploit is now public and may be used.
- CVE-2025-11048Medium
A security vulnerability has been detected in Portabilis i-Educar up to 2.10. Affected by this vulnerability is an unknown functionality of the file /consulta-dispensas. Such manipulation leads to improper authorization. The attack may be launched remotely. The exploit has been disclosed publicly and may be used.
- CVE-2025-11047Medium
A weakness has been identified in Portabilis i-Educar up to 2.10. Affected is an unknown function of the file /module/Api/aluno. This manipulation of the argument aluno_id causes improper authorization. The attack may be initiated remotely. The exploit has been made available to the public and could be exploited.
- CVE-2025-10846Medium
A vulnerability in Portabilis i-Educar up to 2.10 affects unknown code in the file /module/ComponenteCurricular/edit. Manipulation of the argument ID causes SQL injection. The attack can be carried out remotely. The exploit has been publicly disclosed and may be utilized.
- CVE-2025-10845Medium
A vulnerability was found in Portabilis i-Educar up to 2.10. This affects an unknown part of the file /module/ComponenteCurricular/view. The manipulation of the argument ID results in SQL injection. The attack can be executed remotely. The exploit has been made public and could be used.
- CVE-2025-10608Medium
A vulnerability was detected in Portabilis i-Educar up to 2.10. The affected element is an unknown function of the file /enrollment-history/. Performing manipulation results in improper access controls. The attack is possible to be carried out remotely. The exploit is now public and may be used.
- CVE-2025-10605Medium
A security flaw has been discovered in Portabilis i-Educar up to 2.10, affecting /agenda_preferencias.php. Manipulation of the tipoacao argument results in cross-site scripting (XSS), and the attack can be launched remotely. The exploit has been publicly released.
Original NVD description (English source)
A weakness has been identified in Portabilis i-Educar up to 2.10. Affected by this vulnerability is an unknown functionality of the file /intranet/educar_usuario_cad.php of the component Editar usuário Page. This manipulation of the argument email/data_inicial/data_expiracao causes cross site scripting. It is possible to initiate the attack remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2.12 addresses this issue. Patch name: 5b11c0376fcef7ada4c90760b0ca1ed2f16c4de9. You should upgrade the affected component.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

