CVE Catalog

CVE-2024-8517

CriticalCVSS 9.8
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Very high risk
94.53%

100th percentile - higher than 100% of all known CVEs

Summary

SPIP before 4.3.2, 4.2.16, and 4.1.18 is vulnerable to command injection. A remote, unauthenticated attacker can execute arbitrary operating system commands by sending a crafted multipart file upload HTTP request.

Risk Assessment

An unauthenticated attacker can take control of the server and execute arbitrary commands, leading to full system compromise.

Recommendation

Update SPIP to version 4.3.2, 4.2.16, or 4.1.18 (or later) and restrict access to the administrative interface.

Other vulnerabilities in SPIP

See all
Original NVD description (English source)

SPIP before 4.3.2, 4.2.16, and 4.1.18 is vulnerable to a command injection issue. A remote and unauthenticated attacker can execute arbitrary operating system commands by sending a crafted multipart file upload HTTP request.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS