CVE Catalog

CVE-2024-0450

MediumCVSS 6.2
Published: Updated: Translated: NVD NIST

Summary

An issue was found in the CPython zipfile module affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior. The module is vulnerable to 'quoted-overlap' zip-bombs which exploit the zip format to create a zip-bomb with a high compression ratio. Fixed versions reject zip archives which overlap entries.

Risk Assessment

This may lead to resource exhaustion (CPU, memory, disk) when processing a malicious zip archive, causing denial of service.

Recommendation

Update CPython to a patched version (3.12.2, 3.11.8, 3.10.14, 3.9.19, 3.8.19 or later).

Related vulnerabilities

Original NVD description (English source)

An issue was found in the CPython `zipfile` module affecting versions 3.12.1, 3.11.7, 3.10.13, 3.9.18, and 3.8.18 and prior. The zipfile module is vulnerable to “quoted-overlap” zip-bombs which exploit the zip format to create a zip-bomb with a high compression ratio. The fixed versions of CPython makes the zipfile module reject zip archives which overlap entries in the archive.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS