CVE Catalog

CVE-2023-7318

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.59%

47th percentile - higher than 47% of all known CVEs

Summary

Nagios XI versions prior to 2024R1.0.2 are vulnerable to cross-site scripting (XSS) via the Nagios Core Command Expansion page. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Risk Assessment

The vulnerability allows an attacker to execute arbitrary JavaScript in the victim's browser, potentially leading to session or credential theft. The risk is high in multi-user environments.

Recommendation

Update Nagios XI to version 2024R1.0.2 or later. Verifying proper input escaping on the Command Expansion page is also recommended.

Other vulnerabilities in Nagios XI

See all
Original NVD description (English source)

Nagios XI versions prior to < 2024R1.0.2 are vulnerable to cross-site scripting (XSS) via the Nagios Core Command Expansion page. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS