CVE-2023-53907
MediumCVSS 6.5Exploitation Probability (EPSS)
Elevated risk57th percentile - higher than 57% of all known CVEs
Summary
Bludit versions before 3.13.0 contain an authenticated file download vulnerability in the Backup Plugin that allows logged-in users to access arbitrary files. Attackers can manipulate file path parameters to read sensitive system files through directory traversal.
Risk Assessment
An authenticated attacker can read sensitive system files such as configurations or credentials, potentially leading to further escalation. The risk affects Bludit installations with the Backup plugin enabled.
Recommendation
Update Bludit to version 3.13.0 or later. Restrict access to the Backup plugin to trusted administrators only.
Other vulnerabilities in Bludit
See all- CVE-2026-72576Medium
A stored cross-site scripting (XSS) vulnerability in Bludit 4.0.0-beta allows a low-privileged authenticated user (Author role) to inject arbitrary JavaScript by uploading a crafted SVG file as the site logo.
- CVE-2026-46657High
Bludit prior to version 3.22.0 has a vulnerability in the user management logic that allows deactivated accounts to maintain access via persistent authentication tokens. When an administrator disables a user account, the application fails to invalidate or clear the associated tokenAuth and tokenRemember fields in the JSON database. Consequently, any user with a pre-existing "Remember Me" cookie can bypass the account disablement and maintain a valid authenticated state.
- CVE-2026-46656High
Bludit prior to version 3.22.0 has a Broken Access Control flaw where active sessions remain valid even after the user account is deleted from the database. This allows revoked users to maintain unauthorized access.
- CVE-2026-27742Medium
Bludit 3.16.2 contains a stored XSS vulnerability in the post content functionality. The application performs client-side sanitation but lacks server-side enforcement. An authenticated user can inject arbitrary JavaScript into post content, which is stored and rendered to other users without proper output encoding.
- CVE-2026-27741Medium
Bludit 3.16.1 has a CSRF vulnerability in the /admin/uninstall-plugin/ and /admin/install-theme/ endpoints. Lack of CSRF tokens or request origin validation allows an attacker to trick an authenticated admin into performing unauthorized actions.
- CVE-2020-19228High
An issue was found in Bludit v3.13.0 where an unsafe implementation of the backup plugin allows attackers to upload arbitrary files to the server.
Original NVD description (English source)
Bludit versions before 3.13.0 contain an authenticated file download vulnerability in the Backup Plugin that allows logged-in users to access arbitrary files. Attackers can exploit the plugin's download functionality by manipulating file path parameters to read sensitive system files through directory traversal.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

