CVE-2023-49090
MediumCVSS 6.8Summary
CarrierWave is a solution for file uploads for Rails, Sinatra and other Ruby web frameworks. CarrierWave has a Content-Type allowlist bypass vulnerability, possibly leading to XSS. The validation in allowlisted_content_type? determines Content-Type permissions by performing a partial match. If the content_type argument is crafted by an attacker, Content-Types not included in the allowlist will be allowed. This issue has been patched in versions 2.2.5 and 3.0.5.
Risk Assessment
An attacker can upload a file with a dangerous content type, potentially leading to XSS and execution of malicious script in the user's browser. This may result in session or data theft.
Recommendation
Update CarrierWave to version 2.2.5 or 3.0.5 (or later). Ensure content type validation is strict.
Other vulnerabilities in CarrierWave
See all- CVE-2024-29034Medium
CarrierWave did not fully address CVE-2023-49090. When uploading to object storage (e.g., Amazon S3), it is possible to set a Content-Type value that browsers interpret differently from what content_type_allowlist permits, by providing multiple comma-separated values.
- CVE-2026-44587Medium
In the CarrierWave framework, versions prior to 2.2.7 and 3.1.3, the content_type_denylist check fails to properly handle regex metacharacters in string entries, leading to intended content types not being blocked. As a result, applications may be vulnerable to XSS attacks through uploading SVG files containing malicious JavaScript.
Original NVD description (English source)
CarrierWave is a solution for file uploads for Rails, Sinatra and other Ruby web frameworks. CarrierWave has a Content-Type allowlist bypass vulnerability, possibly leading to XSS. The validation in `allowlisted_content_type?` determines Content-Type permissions by performing a partial match. If the `content_type` argument of `allowlisted_content_type?` is passed a value crafted by the attacker, Content-Types not included in the `content_type_allowlist` will be allowed. This issue has been patched in versions 2.2.5 and 3.0.5.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

