CVE-2023-4454
MediumCVSS 5.7Exploitation Probability (EPSS)
Low risk14th percentile - higher than 14% of all known CVEs
Summary
A Cross-Site Request Forgery (CSRF) vulnerability exists in the GitHub repository wallabag/wallabag prior to version 2.6.3. An attacker can exploit this flaw to perform unauthorized actions on behalf of the user.
Risk Assessment
The organization may be exposed to unauthorized operations, potentially leading to data loss or user privacy breaches.
Recommendation
It is recommended to upgrade to version 2.6.3 or later to mitigate this vulnerability.
Other vulnerabilities in wallabag
See all- CVE-2026-110228Medium
wallabag 2.6.13 through 2.6.14 contains a stored cross-site scripting vulnerability that allows authenticated users to host arbitrary HTML by triggering a failed Pocket HTML, Pocket CSV or Shaarli import. Attackers can upload an HTML file with script but no anchor elements, leaving it at the predictable /uploads/import/<user-id>.html path to execute script in victims' wallabag sessions.
- CVE-2026-82089High
The wallabag (aka fr.gaulupeau.apps.InThePoche) application through 2.6.0 for Android allows XSS because /api/entries data is loaded into a WebView.
- CVE-2026-82081Medium
wallabag versions 2 through 2.6.14 are vulnerable to SSRF because a crafted title or content field is mishandled during PDF export.
- CVE-2023-4455Medium
A Cross-Site Request Forgery (CSRF) vulnerability exists in the GitHub repository wallabag/wallabag prior to version 2.6.3. This allows attackers to send unauthorized requests on behalf of users.
Original NVD description (English source)
Cross-Site Request Forgery (CSRF) in GitHub repository wallabag/wallabag prior to 2.6.3.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

