CVE-2023-35946
MediumCVSS 6.9Exploitation Probability (EPSS)
Low risk19th percentile - higher than 19% of all known CVEs
Summary
Gradle, a build automation tool, has a vulnerability that allows files to be written to unintended locations in the filesystem through specially crafted dependency coordinates. This could lead to poisoning the dependency cache or overwriting important files.
Risk Assessment
Organizations may be exposed to attacks that exploit this vulnerability to manipulate the dependency cache or overwrite critical files in the system, potentially leading to serious security issues.
Recommendation
It is recommended to upgrade to Gradle versions 7.6.2 or 8.2, which contain security fixes. If upgrading is not possible, enabling dependency verification is advised to make exploitation of this vulnerability more difficult.
Other vulnerabilities in Gradle
See all- CVE-2016-6199Critical
The ObjectSocketWrapper.java in Gradle 2.12 has a vulnerability that allows remote attackers to execute arbitrary code via a crafted serialized object.
- CVE-2023-44387Low
Vulnerability in Gradle when copying or archiving symlinked files. Gradle resolves the symlink but applies the permissions of the symlink itself instead of the linked file, resulting in files having too many permissions. Fixed in versions 7.6.3, 8.4 and above.
- CVE-2023-35947Medium
Gradle has a path traversal vulnerability when unpacking Tar archives, which may lead to overwriting important files in locations where the Gradle process has write permissions. An attacker can exploit this flaw by controlling the source of an archive or modifying the build to interact with a malicious archive.
- CVE-2021-32751High
Gradle before version 7.2 contains a vulnerability to arbitrary code execution in start scripts generated by the `application` plugin and in the `gradlew` script. An attacker who can change environment variables for the user running the script can cause arbitrary code execution. This issue has been patched in Gradle 7.2 by removing the use of `eval` and requiring the use of the `bash` shell.
- CVE-2021-29428High
In Gradle before version 7.0, on Unix-like systems, the system temporary directory can be created with open permissions that allow multiple users to create and delete files within it. Gradle builds could be vulnerable to a local privilege escalation from an attacker quickly deleting and recreating files in the system temporary directory. This vulnerability impacted builds using precompiled script plugins written in Kotlin DSL and tests for Gradle plugins written using ProjectBuilder or TestKit. If you are on Windows or modern versions of macOS, you are not vulnerable. If you are on a Unix-like operating system with the "sticky" bit set on your system temporary directory, you are not vulnerable. The problem has been patched and released with Gradle 7.0. As a workaround, on Unix-like operating systems, ensure that the "sticky" bit is set. This only allows the original user (or root) to delete a file. If you are unable to change the permissions of the system temporary directory, you can move the Java temporary directory by setting the System Property `java.io.tmpdir`. The new path needs to limit permissions to the build user only. For additional details refer to the referenced GitHub Security Advisory.
- CVE-2021-29429Medium
In Gradle before version 7.0, files created with open permissions in the system temporary directory can allow an attacker to access information downloaded by Gradle. Some builds could be vulnerable to a local information disclosure, as remote files accessed through TextResourceFactory are downloaded into the system temporary directory first. If you do not use the TextResourceFactory API, you are not vulnerable.
Original NVD description (English source)
Gradle is a build tool with a focus on build automation and support for multi-language development. When Gradle writes a dependency into its dependency cache, it uses the dependency's coordinates to compute a file location. With specially crafted dependency coordinates, Gradle can be made to write files into an unintended location. The file may be written outside the dependency cache or over another file in the dependency cache. This vulnerability could be used to poison the dependency cache or overwrite important files elsewhere on the filesystem where the Gradle process has write permissions. Exploiting this vulnerability requires an attacker to have control over a dependency repository used by the Gradle build or have the ability to modify the build's configuration. It is unlikely that this would go unnoticed. A fix has been released in Gradle 7.6.2 and 8.2 to protect against this vulnerability. Gradle will refuse to cache dependencies that have path traversal elements in their dependency coordinates. It is recommended that users upgrade to a patched version. If you are unable to upgrade to Gradle 7.6.2 or 8.2, `dependency verification` will make this vulnerability more difficult to exploit.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

