CVE-2023-34453
MediumCVSS 5.9Exploitation Probability (EPSS)
Elevated risk74th percentile - higher than 74% of all known CVEs
Summary
The snappy-java library has a vulnerability related to unchecked multiplications, which may lead to integer overflow in versions prior to 1.1.10.1. The `shuffle(int[] input)` function can cause a critical error when the array length is not properly checked.
Risk Assessment
This vulnerability may lead to application crashes, threatening the stability of systems using this library. In the event of errors such as `java.lang.ArrayIndexOutOfBoundsException`, unexpected application behavior may occur.
Recommendation
It is recommended to upgrade to version 1.1.10.1, which contains a patch addressing this vulnerability. Additionally, testing the application after the upgrade is advised to ensure no new issues arise.
Other vulnerabilities in snappy-java
See all- CVE-2026-116590Medium
snappy-java is a Java port of the snappy, a fast C++ compresser/decompresser developed by Google. Prior to 1.1.10.9, Snappy.arrayCopy(Object src, int offset, int byteLength, Object dest, int destOffset) passes caller-supplied ranges to native memcpy without validating either array, allowing negative or oversized byteLength and offset values to read or write outside array bounds and crash the JVM. SnappyOutputStream.rawWrite and SnappyInputStream.rawRead, including their typed-array write and read methods, pass caller-controlled ranges through this primitive, and typed-array byte-size calculations can overflow int. This issue is fixed in version 1.1.10.9.
- CVE-2026-108106High
Xerial snappy-java before 1.1.10.9 contains an unbounded memory allocation vulnerability that allows attackers to exhaust JVM memory by declaring a large uncompressed length in compressed input. Attackers can supply a few crafted bytes to Snappy.uncompress, uncompressString, SnappyInputStream or SnappyFramedInputStream to force allocations up to 2 GB, causing OutOfMemoryError and denial of service.
- CVE-2026-108104Medium
Xerial snappy-java from 1.1.7.4 before 1.1.10.10 contains a double release vulnerability in SnappyFramedInputStream that returns pooled buffers twice when replacement allocation fails. Attackers can supply framed data with a large declared chunk length to trigger OutOfMemoryError, causing shared backing arrays that expose or overwrite other streams' decompressed data.
- CVE-2026-93452High
snappy-java through 1.1.10.8 contains a buffer overflow vulnerability in Snappy.compress(ByteBuffer, ByteBuffer) that writes past the end of the destination buffer. Attackers can supply incompressible data that exceeds the destination buffer's remaining capacity, corrupting off-heap memory and causing JVM termination.
- CVE-2026-93451Medium
snappy-java through 1.1.10.8 contains a buffer overflow vulnerability in typed Snappy.uncompress*Array methods that allocate output arrays by dividing uncompressed length by element size but pass the undivided length to native code. Attackers controlling compressed input can cause misaligned length values to write past array bounds with attacker-controlled bytes, corrupting heap memory.
- CVE-2026-90559High
snappy-java through 1.1.10.8 contains an out-of-bounds write vulnerability in Snappy.uncompress(ByteBuffer, ByteBuffer) because destination buffer capacity is never validated against decompressed size. Attackers can supply valid compressed data that decompresses larger than the destination buffer, causing writes past buffer boundaries and JVM termination.
- CVE-2023-34455High
The snappy-java library has a flaw related to unchecked chunk length that can lead to a critical error in versions prior to 1.1.10.1. The hasNextChunk function does not validate the chunkSize variable, which can result in a NegativeArraySizeException or OutOfMemoryError.
- CVE-2023-34454Medium
The snappy-java library has an issue with unchecked multiplications that may lead to integer overflow in versions prior to 1.1.10.1. The `compress(char[] input)` function does not check the length of the array, which can result in critical errors.
Original NVD description (English source)
snappy-java is a fast compressor/decompressor for Java. Due to unchecked multiplications, an integer overflow may occur in versions prior to 1.1.10.1, causing a fatal error. The function `shuffle(int[] input)` in the file `BitShuffle.java` receives an array of integers and applies a bit shuffle on it. It does so by multiplying the length by 4 and passing it to the natively compiled shuffle function. Since the length is not tested, the multiplication by four can cause an integer overflow and become a smaller value than the true size, or even zero or negative. In the case of a negative value, a `java.lang.NegativeArraySizeException` exception will raise, which can crash the program. In a case of a value that is zero or too small, the code that afterwards references the shuffled array will assume a bigger size of the array, which might cause exceptions such as `java.lang.ArrayIndexOutOfBoundsException`. The same issue exists also when using the `shuffle` functions that receive a double, float, long and short, each using a different multiplier that may cause the same issue. Version 1.1.10.1 contains a patch for this vulnerability.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

