CVE-2023-33178
MediumCVSS 6.5Exploitation Probability (EPSS)
Low risk45th percentile - higher than 45% of all known CVEs
Summary
An SQL injection vulnerability was discovered in the Xibo content management system in the `/dataset/data/{id}` API. This allows an authenticated user to exfiltrate data from the Xibo database by injecting specially crafted values into the `filter` parameter.
Risk Assessment
This vulnerability may lead to unauthorized access to sensitive data in the database, posing a serious security threat to the organization.
Recommendation
It is recommended to upgrade to version 2.3.17 or 3.3.5, which fix this issue. There are no other workarounds aside from upgrading.
Other vulnerabilities in Xibo CMS
See all- CVE-2023-33177High
A path traversal vulnerability exists in the Xibo CMS that allows an authenticated user to upload a specially crafted zip file. This can lead to the creation of files outside the CMS library directory, enabling remote code execution.
- CVE-2026-42558High
Xibo CMS prior to version 4.4.2 contains a vulnerability chain of Stored XSS and Iframe Sandbox escape. Users with DataSet permissions can use the Data Connector to craft messages that escape the sandbox and enable XSS.
- CVE-2026-42141High
Xibo is an open source digital signage platform that prior to version 4.4.1 had a Server-Side Request Forgery (SSRF) vulnerability. This allows users with Library upload permissions to make arbitrary HTTP requests from the CMS server to network resources.
- CVE-2025-62369High
Xibo, an open source digital signage platform with a CMS, versions 4.3.0 and below contain a remote code execution vulnerability in the Developer menu's Module Templating functionality. Authenticated users with permissions to add/edit custom modules and templates can manipulate Twig filters and execute arbitrary server-side functions as the web server user. The issue is fixed in version 4.3.1.
- CVE-2025-41089Medium
Reflected Cross-Site Scripting (XSS) in Xibo CMS v4.1.2 from Xibo Signage, due to a lack of proper validation of user input. To exploit the vulnerability, the attacker must create a template in the 'Templates' section, then add an element that has the 'Configuration Name' field, such as the 'Clock' widget. Next, modify the 'Configuration Name' field in the left-hand section.
- CVE-2025-41088Medium
Stored Cross-Site Scripting (XSS) in Xibo Signage's Xibo CMS v4.1.2, due to a lack of proper validation of user input. To exploit the vulnerability, the attacker must create a template in the 'Templates' section, then add a text element in the 'Global Elements' section, and finally modify the 'Text' field in the section with the malicious payload.
- CVE-2023-33181Medium
Xibo is a content management system (CMS) that in versions from 3.0.0 to 3.3.5 reveals sensitive information by printing stack traces when certain API routes are called with missing or invalid parameters. Users should upgrade to version 3.3.5, which fixes this issue.
- CVE-2023-33180Medium
An SQL injection vulnerability was discovered in the Xibo content management system in the `/display/map` API route, affecting versions from 3.2.0 to 3.3.2. This allows an authenticated user to exfiltrate data from the Xibo database by injecting specially crafted values into the `bounds` parameter.
- CVE-2023-33179Medium
An SQL injection vulnerability was discovered in the `nameFilter` function in the Xibo content management system, affecting versions from 3.2.0 to 3.3.5. This allows an authenticated user to exfiltrate data from the Xibo database by injecting specially crafted values for logical operators.
Original NVD description (English source)
Xibo is a content management system (CMS). An SQL injection vulnerability was discovered in the `/dataset/data/{id}` API route inside the CMS starting in version 1.4.0 and prior to versions 2.3.17 and 3.3.5. This allows an authenticated user to exfiltrate data from the Xibo database by injecting specially crafted values in to the `filter` parameter. Values allowed in the filter parameter are checked against a deny list of commands that should not be allowed, however this checking was done in a case sensitive manor and so it is possible to bypass these checks by using unusual case combinations. Users should upgrade to version 2.3.17 or 3.3.5, which fix this issue. There are no workarounds aside from upgrading.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

