CVE Catalog

CVE-2023-32070

CriticalCVSS 9.0
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.65%

51th percentile - higher than 51% of all known CVEs

Summary

XWiki Platform prior to version 14.6-rc-1 did not check for dangerous attributes or attribute values during HTML rendering. This allowed cross-site scripting (XSS) attacks via attributes and link URLs supported in XWiki syntax. The issue is patched in XWiki 14.6-rc-1.

Risk Assessment

An attacker can inject malicious script that executes in a user's browser, potentially leading to session or data theft. The risk affects organizations exposing editable wiki pages to users.

Recommendation

Upgrade XWiki to version 14.6-rc-1 or later. There are no known workarounds other than upgrading.

Other vulnerabilities in XWiki Platform

See all
Original NVD description (English source)

XWiki Platform is a generic wiki platform. Prior to version 14.6-rc-1, HTML rendering didn't check for dangerous attributes/attribute values. This allowed cross-site scripting (XSS) attacks via attributes and link URLs, e.g., supported in XWiki syntax. This has been patched in XWiki 14.6-rc-1. There are no known workarounds apart from upgrading to a fixed version.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS