CVE-2023-30549
HighCVSS 7.1Exploitation Probability (EPSS)
Low risk30th percentile - higher than 30% of all known CVEs
Summary
Apptainer is an open source container platform for Linux. There is an ext4 use-after-free flaw that is exploitable through versions of Apptainer < 1.1.0 and installations that include apptainer-suid < 1.1.8 on older operating systems where that CVE has not been patched, including Red Hat Enterprise Linux 7, Debian 10 buster, Ubuntu 18.04 bionic and Ubuntu 20.04 focal. Use-after-free flaws in the kernel can be used to attack the kernel for denial of service and potentially for privilege escalation.
Risk Assessment
Organizations using vulnerable Apptainer versions on the listed operating systems are exposed to attacks leading to denial of service or privilege escalation, which could result in system compromise.
Recommendation
Update Apptainer to version 1.1.8 or later, which by default disables mounting of extfs filesystem types in setuid-root mode. Alternatively, do not install apptainer-suid (for versions 1.1.0 through 1.1.7) or set `allow setuid = no` in apptainer.conf, and consider limiting containers using the `limit containers` options and `allow container extfs = no`.
Other vulnerabilities in Apptainer
See all- CVE-2026-48785Medium
Apptainer before version 1.5.1 has a vulnerability in Image.AuthorizedPath that applies plain string-prefix matching to the limit container paths directive in apptainer.conf, so an allowed path such as /data/safe also authorizes a sibling path such as /data/safe-but-unsafe. A local user can consequently run a container from a directory outside the administrator's intended allowlist when Apptainer operates in setuid mode.
- CVE-2025-65105Medium
Apptainer versions less than 1.4.5 allow a container to disable two forms of the little-used --security option, specifically --security=apparmor:<profile> and --security=selinux:<label>, which otherwise restrict container operations. The --security option is documented as a root feature, but these forms also work for unprivileged users on systems where the corresponding feature is enabled. The vulnerability is fixed in 1.4.5.
- CVE-2023-38496Medium
Apptainer is an open source container platform. Version 1.2.0-rc.2 introduced an ineffective privilege drop when requesting container network setup, allowing subsequent functions to be called with root privileges.
Original NVD description (English source)
Apptainer is an open source container platform for Linux. There is an ext4 use-after-free flaw that is exploitable through versions of Apptainer < 1.1.0 and installations that include apptainer-suid < 1.1.8 on older operating systems where that CVE has not been patched. That includes Red Hat Enterprise Linux 7, Debian 10 buster (unless the linux-5.10 package is installed), Ubuntu 18.04 bionic and Ubuntu 20.04 focal. Use-after-free flaws in the kernel can be used to attack the kernel for denial of service and potentially for privilege escalation. Apptainer 1.1.8 includes a patch that by default disables mounting of extfs filesystem types in setuid-root mode, while continuing to allow mounting of extfs filesystems in non-setuid "rootless" mode using fuse2fs. Some workarounds are possible. Either do not install apptainer-suid (for versions 1.1.0 through 1.1.7) or set `allow setuid = no` in apptainer.conf. This requires having unprivileged user namespaces enabled and except for apptainer 1.1.x versions will disallow mounting of sif files, extfs files, and squashfs files in addition to other, less significant impacts. (Encrypted sif files are also not supported unprivileged in apptainer 1.1.x.). Alternatively, use the `limit containers` options in apptainer.conf/singularity.conf to limit sif files to trusted users, groups, and/or paths, and set `allow container extfs = no` to disallow mounting of extfs overlay files. The latter option by itself does not disallow mounting of extfs overlay partitions inside SIF files, so that's why the former options are also needed.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

