CVE-2023-25957
CriticalCVSS 9.1Exploitation Probability (EPSS)
Low risk47th percentile - higher than 47% of all known CVEs
Summary
The affected versions of the Mendix SAML module insufficiently verify SAML assertions. An unauthenticated remote attacker could bypass authentication and gain access to the application. For compatibility reasons, fixed versions still contain this issue, but only when the recommended default configuration option 'Use Encryption' is disabled.
Risk Assessment
An attacker could gain unauthorized access to the application, potentially leading to confidentiality and integrity breaches.
Recommendation
Update the Mendix SAML module to the fixed versions (e.g., V1.17.3, V2.3.0, V3.3.1, V3.3.0, V3.2.7, V3.2.6) and ensure 'Use Encryption' is enabled. Verify the SAML configuration.
Other vulnerabilities in Mendix SAML
See all- CVE-2023-29129Critical
The Mendix SAML module in multiple versions insufficiently verifies SAML assertions. This could allow unauthenticated remote attackers to bypass authentication and gain access to the application. The vulnerability affects specific module versions for Mendix 7, 8, and 9.
- CVE-2026-89209Medium
The Mendix SAML module (Mendix 9, 10, and 11 compatible versions before V3.6.29 and V4.2.4 respectively) does not properly protect against SAML assertion replay in IdP-initiated authentication flows. This could allow unauthenticated remote attackers to gain unauthorized access by replaying a valid SAML response.
- CVE-2026-80465High
The Mendix SAML module in versions before V4.2.4 (for Mendix 10 and 11) and before V3.6.29 (for Mendix 9.24) does not properly validate the SAML response signature. In specific SSO configurations, this could allow unauthenticated remote attackers to hijack an account or session.
Original NVD description (English source)
A vulnerability has been identified in Mendix SAML (Mendix 7 compatible) (All versions >= V1.16.4 < V1.17.3), Mendix SAML (Mendix 8 compatible) (All versions >= V2.2.0 < V2.3.0), Mendix SAML (Mendix 9 latest compatible, New Track) (All versions >= V3.1.9 < V3.3.1), Mendix SAML (Mendix 9 latest compatible, Upgrade Track) (All versions >= V3.1.8 < V3.3.0), Mendix SAML (Mendix 9.6 compatible, New Track) (All versions >= V3.1.9 < V3.2.7), Mendix SAML (Mendix 9.6 compatible, Upgrade Track) (All versions >= V3.1.8 < V3.2.6). The affected versions of the module insufficiently verify the SAML assertions. This could allow unauthenticated remote attackers to bypass authentication and get access to the application. For compatibility reasons, fix versions still contain this issue, but only when the recommended, default configuration option `'Use Encryption'` is disabled.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

