CVE Catalog

CVE-2023-22972

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.43%

36th percentile - higher than 36% of all known CVEs

Summary

OpenEMR before 7.0.0 contains a reflected cross-site scripting vulnerability in interface/forms/eye_mag/php/eye_mag_functions.php. Remote authenticated users can inject arbitrary web script or HTML via REQUEST_URI.

Risk Assessment

An authenticated attacker can execute a malicious script in other medical system users' browsers, risking session theft and access to patient data.

Recommendation

Update OpenEMR to version 7.0.0 or later and implement proper input encoding and validation, especially for REQUEST_URI.

Other vulnerabilities in OpenEMR

See all
Original NVD description (English source)

A Reflected Cross-site scripting (XSS) vulnerability in interface/forms/eye_mag/php/eye_mag_functions.php in OpenEMR < 7.0.0 allows remote authenticated users to inject arbitrary web script or HTML via the REQUEST_URI.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS