CVE Catalog

CVE-2021-37600

MediumCVSS 5.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Elevated risk
0.66%

50th percentile - higher than 50% of all known CVEs

Summary

An integer overflow in util-linux through 2.37.1 can potentially cause a buffer overflow if an attacker were able to use system resources in a way that leads to a large number in the /proc/sysvipc/sem file. According to the vendor, this is unexploitable in GNU C Library environments and possibly in all realistic environments.

Risk Assessment

Theoretically the vulnerability could lead to a buffer overflow, but in practice it is considered unexploitable in realistic environments. The risk to the organization is low.

Recommendation

Upgrade util-linux to a version newer than 2.37.1 when available. Monitor official vendor advisories regarding this vulnerability.

Other vulnerabilities in util-linux

See all
Original NVD description (English source)

An integer overflow in util-linux through 2.37.1 can potentially cause a buffer overflow if an attacker were able to use system resources in a way that leads to a large number in the /proc/sysvipc/sem file. NOTE: this is unexploitable in GNU C Library environments, and possibly in all realistic environments.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS