CVE-2021-20305
HighCVSS 8.1Exploitation Probability (EPSS)
High risk77th percentile - higher than 77% of all known CVEs
Summary
A flaw was found in Nettle in versions before 3.7.2, where several Nettle signature verification functions (GOST DSA, EDDSA & ECDSA) result in the Elliptic Curve Cryptography point (ECC) multiply function being called with out-of-range scalers, possibly resulting in incorrect results. This flaw allows an attacker to force an invalid signature, causing an assertion failure or possible validation. The highest threat to this vulnerability is to confidentiality, integrity, as well as system availability.
Risk Assessment
The vulnerability may allow an attacker to bypass signature verification or cause a crash, threatening confidentiality, integrity, and availability of systems using Nettle.
Recommendation
Upgrade Nettle to version 3.7.2 or later and verify signature verification correctness in applications using this library.
Other vulnerabilities in Nettle
See all- CVE-2016-6489High
The RSA and DSA decryption code in Nettle makes it easier for attackers to discover private keys via a cache side channel attack.
- CVE-2015-8805Critical
The ecc_256_modq function in ecc-256.c in Nettle before 3.2 does not properly handle carry propagation, leading to incorrect output in its implementation of the P-256 NIST elliptic curve.
- CVE-2015-8804Critical
In Nettle versions before 3.2, the x86_64/ecc-384-modp.asm file does not properly handle carry propagation, leading to incorrect output in its implementation of the P-384 NIST elliptic curve.
- CVE-2021-3580High
A flaw was found in the way nettle's RSA decryption functions handled specially crafted ciphertext. An attacker could use this flaw to provide a manipulated ciphertext leading to application crash and denial of service.
Original NVD description (English source)
A flaw was found in Nettle in versions before 3.7.2, where several Nettle signature verification functions (GOST DSA, EDDSA & ECDSA) result in the Elliptic Curve Cryptography point (ECC) multiply function being called with out-of-range scalers, possibly resulting in incorrect results. This flaw allows an attacker to force an invalid signature, causing an assertion failure or possible validation. The highest threat to this vulnerability is to confidentiality, integrity, as well as system availability.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

