CVE Catalog

CVE-2020-36865

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.42%

35th percentile - higher than 35% of all known CVEs

Summary

Nagios XI versions prior to 5.7.2 are vulnerable to cross-site scripting (XSS) via the BPI (Business Process Intelligence) component's Config Management and Edit Config page. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Risk Assessment

An attacker can execute arbitrary JavaScript in the browser of a logged-in Nagios XI administrator, potentially leading to session theft, account takeover, or modification of monitoring configuration.

Recommendation

Upgrade Nagios XI to version 5.7.2 or later. Until patched, restrict access to the web interface to trusted networks only.

Other vulnerabilities in Nagios XI

See all
Original NVD description (English source)

Nagios XI versions prior to 5.7.2 are vulnerable to cross-site scripting (XSS) via the BPI (Business Process Intelligence) component’s Config Management and Edit Config page. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS