CVE-2020-27388
MediumCVSS 5.4Exploitation Probability (EPSS)
Low risk44th percentile - higher than 44% of all known CVEs
Summary
Multiple stored XSS vulnerabilities exist in the YOURLS Admin Panel, versions 1.5-1.7.10. An authenticated user can inject malicious code by modifying a PHP plugin and uploading it.
Risk Assessment
An attacker can execute arbitrary scripts in other administrators' browsers, leading to session theft, configuration changes, or data theft.
Recommendation
Immediately update YOURLS to the latest version and restrict plugin modification permissions to trusted users only.
Other vulnerabilities in YOURLS
See all- CVE-2026-62858Medium
YOURLS prior to 1.10.5 does not sanitize the request path in yourls_get_request(), so dot and slash traversal sequences are preserved and reach file_exists() and include() under YOURLS_PAGEDIR. An unauthenticated remote attacker can traverse outside the pages directory and include a local PHP file already present on the server, causing it to execute in the YOURLS web process. The issue is fixed in version 1.10.5.
- CVE-2026-63135High
YOURLS, a self-hosted, customizable URL shortener written in PHP, from version 1.5.1 until 1.10.4 stores the HTTP Referer header and aggregates it in statistics, then passes it to the chart builder which concatenates labels into inline JavaScript without proper escaping. This allows an unauthenticated attacker to poison the statistics of an existing short URL with a crafted referrer, leading to execution of malicious JavaScript in the YOURLS origin when an administrator or public stats-page viewer opens the affected page. This issue is fixed in version 1.10.4.
Original NVD description (English source)
Multiple Stored Cross Site Scripting (XSS) vulnerabilities exist in the YOURLS Admin Panel, Versions 1.5 - 1.7.10. An authenticated user must modify a PHP plugin with a malicious payload and upload it, resulting in multiple stored XSS issues.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

